Authentication issue on our applications
Incident Report for ISO
Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 08:39 CEST
Investigating
On September 1, we updated our single sign on platform which allows users to sign in once and be recognized by all systems which are part of the single sign on network.
Since this update, some users have been facing a browser issue preventing them from accessing some ISO platforms.

While we investigate the root cause of this problem, and if you are having trouble accessing ISO platforms, please carry out the following workaround steps:
1. open an ‘incognito/private/anonymous browser session
2. paste the link you want to access in this browser and you will be prompted to enter your username and password

To avoid having to use the ‘incognito mode’ for future log-ins, and while we are solving the root cause of this issue, you will be required to clear your cookies and cache from your regular browser session. To do this, please carry out the following steps:
1. clear your browser cookies and cache (step by step instructions here)
if you are using a Chrome browser, select "all time" when indicating the time rage to clear
2. close and restart your browser
3. paste the link you want to access in your browser

We apologize for the inconvenience. If the problem persists, please contact helpdesk@iso.org
Posted Sep 14, 2022 - 11:08 CEST